Wij ondersteunen de laatste versies van Chrome, Safari, Firefox en Microsoft Edge. Internet Explorer wordt helaas niet meer ondersteund.

Wanneer u een oudere versie gebruikt, kan het zijn dat My EMS niet optimaal werkt. U kunt dan het beste een gratis upgrade naar een recente versie uitvoeren.